NextCloud升级后各种错误解决办法

99 浏览技术资料Nextcloud错误
0

关于您的设置有一些错误。

PHP 内存限制低于建议值 512MB。

解决办法:

进入:/usr/local/php/etc,找到:php.ini,把memory_limit = 128M改大一些。

HTTP 请求头 “X-Frame-Options” 没有配置为 “SAMEORIGIN”。这是一个潜在的安全或隐私风险,我们建议您调整这项设置。

找到nginx配置文件,添加:add_header X-Frame-Options ‘SAMEORIGIN’;

未找到 PHP 的 “fileinfo” 模块。强烈推荐启用该模块,从而获得更好的 MIME 类型探测结果。

这个简单,宝塔面板可以直接在后台安装,Oneinstack可以使用命令:./install.sh –php_extensions fileinfo

您当前正在运行 PHP 版本 7.4.33。我们建议您在您的操作系统发行版支持PHP新版本的时候进行升级,以获得来自 PHP 官方的性能和安全更新↗。

这个以后再说,PHP跨大版本升级太麻烦。

PHP 模块 “gmp” 和/或 “bcmath” 未被启用。如果你使用 WebAuthn 无密码验证,这些模块是必需的。

这个直接就安装:

<code>yum -y install php-gmp</code>
<code>yum -y install php-bcmath</code>

“Referrer-Policy” HTTP 头 未设置到 “no-referrer”、 “no-referrer-when-downgrade”、 “strict-origin”、 “strict-origin-when-cross-origin” 或 “same-origin”。这可能会泄露 refer 信息。见 W3C 建议 ↗

还是一样,找到Nginx配置添加:add_header Referrer-Policy “no-referrer”;


分享到:
Qi 编辑问题 2023年1月11日
添加评论
写下您的答案。

Login

Welcome! Login in to your account

Remember me Lost your password?

Don't have account. Register

Lost Password

Register